Adobe Unit Types.osax not found during merge attempt

Ken Carpenter's Avatar

Ken Carpenter

16 Oct, 2011 08:23 PM

I recently upgraded to Lion and now I am trying to pull changes from my repo and merge them with my local files.

When it asked me to merge (or when I try to remerge) I get an error like this:

Mercurial reported error number 1:
2011-10-16 13:20:08.167 osascript[18358:1207] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found. Did find:

/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper

osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.
/Users/ken/Library/Application Support/MacHg/AraxisScripts/araxishgmerge:475:483: script error: Expected class name but found identifier. (-2741) merging Classes/UnicornRushRoot.mm failed!

I found this discussion: http://forums.adobe.com/thread/486208

which suggests it is some sort of 32-bit/64-bit issue, but I can't see what the actual issue might be in this case.

Any ideas?

Thanks,

Ken

  1. Support Staff 1 Posted by jason on 16 Oct, 2011 09:02 PM

    jason's Avatar

    Which merge tool do you have selected? Other than that it looks like the underlying Mercurial is having problems here. Can you remove this scripting addition and try again?

    Cheers,
    Jas

  2. 2 Posted by Ken Carpenter on 16 Oct, 2011 09:10 PM

    Ken Carpenter's Avatar

    Hi Jas,

    For the output above, I had tried explicitly setting opendiff as the "Other" tool.

    Now I have FileMerge selected and I get the same error. It said it couldn't find it once, but I guess it must have found it, because I can do a diff still.

    I saw the post on opendiff not being found in /usr/bin, but I have opendiff in both /usr/bin and /Developer/usr/bin.

    I just upgraded from Xcode 3.2.6 to Xcode 4.2.

    I'm not sure what you mean by "remove this scripting addition". I didn't knowingly install any scripting add-ons and I don't see anywhere in the MacHG UI to add/remove anything.

    Thanks,

    Ken

  3. Support Staff 3 Posted by jason on 16 Oct, 2011 09:22 PM

    jason's Avatar

    In the very latest MacHg (on bitbucket) but not packaged up and released yet the opendiff issue has been further addressed.

    What I mean by removing it is doing something like the following in the terminal:

    sudo rm -r /Library/ScriptingAdditions/Adobe*

    Make sure you are backed up though...

    Unfortunately I don't have time to look at this right now but it looks to be an underlying adobe problem and not a MacHg problem. If you try the Mercurial command from the command line I am guessing that you will get the same thing MacHg is reporting and thus it's not really something MacHg is doing and more it's something that is going on with your system... (But I could be wrong about this...)

    Cheers,
    Jas

  4. jason closed this discussion on 08 Nov, 2014 02:46 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac