Not recognizing status changes to allow commit

Michael A. Sypes's Avatar

Michael A. Sypes

02 Feb, 2012 05:50 PM

I just hit an odd problem:
Mysteriously, MacHg isn't recognizing that any files in my local repos have been changed to allow commits. I.e., I have modified files, hg status lists them, and I can commit from the command line. However, MacHg's history view indicates I'm still on the last changeset, and both types of commit are greyed out in the menu and toolbar.
I've been using the program for many months now, but this only popped up a day or two ago.
I thought there might be corrupted prefs file, but can't find it.
Thanks.

  1. Support Staff 1 Posted by jason on 02 Feb, 2012 07:11 PM

    jason's Avatar

    You haven't upgraded the command line version or anything right? Also if you use the command line version outside of MacHg sometimes MacHg can get a tiny bit de-synchronized. You can get things back by simply switching to the files view and clicking say Show: Up to date on the rhs checkboxes. and then unclicking it. Anything to regenerate the statuses...

    Did this fix your problem?

    Cheers,
    Jason

  2. jason closed this discussion on 02 Feb, 2012 07:11 PM.

  3. Michael A. Sypes re-opened this discussion on 02 Feb, 2012 08:13 PM

  4. 2 Posted by Michael A. Sype... on 02 Feb, 2012 08:13 PM

    Michael A. Sypes's Avatar

    Thanks, Jason.
    I had unchecked the show modified box. Rechecking that handles the problem. That box, apparently must be kept checked in order to keep the history view accurate.

  5. Support Staff 3 Posted by jason on 02 Feb, 2012 08:54 PM

    jason's Avatar

    Actually only if it gets out of synch then by pushing any of those buttons a refresh occurs... (So toggle it to the state you want and you are good to go again...)

  6. jason closed this discussion on 02 Feb, 2012 08:54 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac