History view hangs in MacHg

wluh's Avatar


05 Mar, 2012 07:07 PM

Hi, I'm using version 0.9.25 on OS X Lion and am having the same problem as discussed here:


It was working fine for awhile and suddenly started hanging. I deleted prefs, and tried viewing history on other repo's. It doesn't matter. It still hangs.

Also, tried reinstalling the app, but that doesn't make a difference.

I thought it was some corrupted pref file that needed to be removed, but I removed prefs and also these other files (found via ActivityMonitor):
~/Library/Caches/com.jasonfharris.MachHg/com.apple.opencl/com.apple.ocl.64.maps ~/Library/Caches/com.jasonfharris.MachHg/com.apple.opencl/com.apple.ocl.64.data ~/Library/Saved Application State/com.jasonfharris.MachHg.savedState/data.data ~/Library/Preferences/com.jasonfharris.MachHg.plist.lockfile

But it still crashes. I end up force quitting, and have attached the crash log. There's a nested recursion in:

[JHAccordionView splitView:resizeSubviewsWithOldSize:]

We've found that NSZeroRect's no longer work in Lion, so maybe that's the issue?

The strange thing is that the Delta view works, and that also pulls history (so does pulling history via the command line), so it's got to be something funky in the UI --- what I don't understand is why it suddenly stopped working.

  1. Support Staff 1 Posted by jason on 05 Mar, 2012 07:44 PM

    jason's Avatar

    Actually i just released a beta version of MacHg 1.0.0. This is hopefully fixed in that version. You can download the beta from: http://jasonfharris.com/machg/downloads.

    Can I ask you to please, give that a try and see if that fixes things? Thanks!


  2. jason closed this discussion on 05 Mar, 2012 07:44 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac