How to enable largefiles extension in machg

vincent.y.fang's Avatar


22 Dec, 2012 02:13 AM

I tried to follow the suggestion of enabling the largefile extension by following the directions on this site and then adding the extension under [extensions]

largefiles =

to the hgrc configuration file in ~/Library/Application Support/MacHg/hgrc
but I keep getting the error 255 This repository uses the largefiles extension. Please enable it in your Mercurial config file.

I've restarted the app and I still continue to get the error. I had to download the mercurial hg from selenic, create my own .hgrc in my home directory, and performed the same fix and that worked. So I can't understand why it's not working for MacHg.

  1. Support Staff 1 Posted by jason on 02 Jan, 2013 07:04 PM

    jason's Avatar

    I haven't actually tested MacHg with the LargeFiles extension. It would be nice for me to get the time to look at it... I can't say when that will be though. Normal work has been insanely busy..

  2. jason closed this discussion on 02 Jan, 2013 07:04 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac